
 

 

 
 

 

 
 

 
 
 
 
 
 
 
 
 

 
 

 

 

Center for Technology & Training (CTT) 

Michigan Tech Transportation Institute 

 

Last Revised: 4/4/2011 

Submitting Local Road Data to TAMC 
 

Ten Steps to Consistent Data 

IMPORTANT NOTE: These instructions are meant for agencies that have NOT begun 
to collect local road rating data for submission to the Transportation Asset Management 
Council (TAMC) for reimbursement. If your agency already has 2011 local road data 
collected and you did NOT follow the Local Road Rating Data Cycle, be sure to call 
the Center for Technology & Training (CTT) for assistance before submitting data to 
TAMC through your regional or metropolitan planning organization. 

 

CTT:  

phone: 906-487-2102   |   email: ctt@mtu.edu 

 

TAMC: 

Brian Sanada – TAMC Coordinator, Michigan DOT 

phone: 517-373-2220   |   email: sanadab@michigan.gov 
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Local Road Ratings Data Cycle 

 

 
  

The process for collecting and submitting local road data to the Transportation Asset 
Management Council (TAMC) is very similar to the process used for providing TAMC with 
federal-aid road data.  
 
Before you begin collecting local road data for TAMC, ensure you are using the latest 
RoadSoft release. Visit www.roadsoft.org/releases/Latest_RoadSoft_Release for RoadSoft 
updates.  
 
If you have any questions or concerns, please call RoadSoft support at 906-487-2102.
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STEP 1 
Define and save a network in RoadSoft for collecting data on your paved 
local roads 
 

a. Start the RoadSoft software. 
 

b. Open the Network/Filter Builder either by right-clicking on the map and selecting Network/Filter 
Builder…, or by clicking on the map toolbar’s Filter button and selecting Network/Filter Builder… 

 
c. Locate your paved local roads in the Network/Filter Builder by adding criteria. 

 In order to select only roads you want to collect data for in the field, select a Field, Operator, and 
Value, then click the Add Criteria button. Once this criteria has been added, the number of Segments 
Found will decrease, thus narrowing your selection (see image below).  

 
NOTE: This step must be done twice: first to select the correct National Function Class, second to select the Surface 
Type. The first set of criteria should be National Function Class = 7-Local. The second criteria set defines your 
Surface Type, and should include only the paved roads in your local road network (e.g. asphalt, seal coat, brick, 
concrete, etc.). 
 

TIP: To select multiple values hold down the control key while left-cliking.  
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d. Save your Network. 
After you have added the critera that selects only the paved roads in your local road network, save the 
network by clicking the Save button located at the top left of the Network/Filter Builder window. Enter a 
Name for your network, and then click the OK button. 

TIP: Using a descriptive file name and adding a date to the network name can help to ensure that you export the correct 
network. 

 

e. Click OK to close the notice showing that your network was successfully saved. 

 

f. Exit the Network/Filter Builder by clicking the close button.  
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STEP 2  
Export the Network for use with the Laptop Data Collector (LDC) 

 

 
a. Open the TAMC menu from the RoadSoft menu bar. Select 1 - (County/City Does This) Export Data for 

LDC… 
 

NOTE: The regional version of RoadSoft is not capable of exporting data for the LDC. Regions must obtain data 
exports directly from the individual agencies within their region. If you have questions please call RoadSoft Technical 
Support at 906-487-2102. 
    

b. Select the network from the drop down list in the Export Data for LDC window. 
The network you want is the one you saved in Step 1d. 
 

c. Define an Export Path; this is the location on your hard drive where you want to save the export file.  
 

d.  Save the export file to the location you specified by clicking the Export button. 

 
 

e. Click OK to close the window confirming a successful export. 
 

 
f. RoadSoft creates a file named “RStoLDC_[jurisdiction]_[date].zip” in the location you specified. Copy this file 

to a CD, floppy disk, or other portable storage device so you can get it onto the laptop that has the RoadSoft 
LDC software installed on it.  
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STEP 3  
Send a copy of the Network to CSS  
 
 
 

Your agency should submit a copy of the exported network to the CSS before beginning data collection. 
 

a. Open your web browser and go to http://tamc.mcgi.state.mi.us/TAMC/  
 

b. Login using your username and password. If you do not have a username and password, click the 
Register button and follow the instructions to receive login information.  

 
c. Select the Data tab. 

 
d. Select the Send Data sub-tab. 

 
e. Click the Browse button and locate your RoadSoft data export. 

 
f. Click the Open button to attach the file. 

 
g. Click the Upload button to submit the data to the TAMC. 

 
 

 
STEP 4 
Import the Network onto the LDC 
 
 

 
NOTE: The combination of a network and a shape file is referred to as a RoadSoft Data Set. Shape files for your 
jurisdiction are located on the Local Agency’s RoadSoft Program CD. If you’re not able to access your RoadSoft CD, 
call RoadSoft Tech Support at 906-487-2102 and specify the jurisdiction you need a shape file for. 
 
There are three possibilities when importing the network and loading the shape file. Identify your 
situation below, and then perform the appropriate procedure: 
 
Situation 1: If you installed the LDC software and you are running it for the first time you will have to import the 
network, and then load the shape file from the Local Agency’s RoadSoft Program CD. To do so, simply follow the 
prompts when you first start the LDC software. 
 
Situation 2: If your LDC already has the shape file loaded of the jurisdiction corresponding with the roads on the 
network you saved, perform Procedure 1. 
 
Situation 3: If the shape file currently loaded on your LDC does NOT correspond with the jurisdiction your TAMC 
network data collection is for, perform Procedure 2. 
 
Procedure 1: Import the Network 

a. Start the LDC software. 
 

b. Insert the portable storage device that contains the “RStoLDC_[jurisdiction]_[date].zip” file from the local 
agency (see Step 2e). 
 

c. From the main LDC screen, select the File menu, then click Import Data from RoadSoft. 
 

d. Click the Browse for File button to locate the “RStoLDC_[jurisdiction]_[date].zip” file on the portable 
storage device. 
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e. If you are absolutely certain any data currently in the LDC has already been backed up, click the Yes button to 

proceed importing the network. If not, click No and backup the data. 

 
Procedure 2: Swap the Shape File and then Import the Network 

a. From the LDC main menu, click on the File menu and select Swap Jurisdiction. 
 The Insert CD window opens indicating that your RoadSoft Program CD must be inserted. 

 
b. Insert the RoadSoft Program CD containing the correct shape file. 

 
c. Click the OK button to replace the existing shape file. 
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The LDC loads the new shape file. The Data Not Found prompt opens. 
 

 
d. Click the OK button. 

The Import Data window opens. 

 
 

e. Click the Browse for File button to locate the “RStoLDC_[jurisdiction]_[date].zip” file on the portable 
storage device. 

Upon successfully importing the network, the Define Work Crew window opens. Cancel to close 
the LDC or define the crew and click OK to begin preparing for data collection. 
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STEP 5 
Connect the GPS to your laptop and begin collecting data 
 
 

 
To Connect the GPS: 

a. Start the LDC software. 
 

b. With your GPS device turned off, connect it to your laptop using the Serial or USB connection. 
 
NOTE: If you GPS is on before connecting it, your mouse pointer may jump around erratically. If this happens, turn off 
your GPS, leave it connected, and restart windows and the LDC. 

 
c. Turn on your GPS and wait for it to acquire a position (this could take a couple of minutes). 

 
d. From the LDC main menu open the GPS menu and select Connect to establish communication between the 

GPS and the LDC software. Wait a few minutes for the software to snap to the GPS position on the GIS map. 
  
NOTE: If you’re not on or near a road segment that is part of the network that you imported into the LDC software, the 
software will not be able to snap to a segment on the GIS map. 
 
 
To Collect Data: 

Use the following shortcut keys to enter data into the LDC software: 
 

Ctrl + S  Surface Type 
Ctrl + 0–9  PASER Rating 
Shift-Ctrl + 0–9 Number of Lanes 
Ctrl + Enter  Submit (save) Data  
Ctrl + +/-  Zoom In/Out 
Ctrl + Arrow Keys Pan the GIS Map  
Ctrl + Space Bar Hold/Release Segment 
 

For a complete list of shortcut keys, open the Help menu and select Shortcut Keys. 
 
IMPORTANT: While collecting data, back up every hour or as often as conveniently possible. From the main LDC 
menu select the File menu, then Backup/Restore to back up your data. If data collection spans multiple days, export 
the data every day and save a copy of the data file (LDCtoRS_[jurisdiction]_[date].zip) to a CD, jump drive, or floppy 
disk. 
 
TIP: The RSM History grid (shown below) provides a history of PASER ratings for the current segment. Viewing past 
PASER ratings before rating a segment can influence the rating. To avoid possibly influencing the current rating based 
on past ratings; this grid will not be visible until you submit a rating for the segment.  Editing the rating after that point 
will require an explanation. 
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STEP 6 
Export collected data from the LDC 
 

After collecting data using the LDC, migrate that data back onto your local agency’s version of 
RoadSoft by first exporting it from the LDC. 

 
a. From the LDC main menu select the File menu, then Export Data to RoadSoft…  

 
b. In the Export Path field, enter a location on your hard drive to save the export file. Click the Browse Folder 

button to browse your hard drive. 
 

NOTE: Windows will not allow you to export the data directly to a portable storage device. Select a location on your 
hard drive. If you have an existing data export in the folder you select, a notice will display. Click Yes to replace the 
existing file, or click No to append the new data to the existing file. 

 

 
c. Click the OK button once the Export Complete notice displays. 

 

 
 

d. Copy the “LDCtoRS_[Jurisdiction]_[date].zip” file to a portable storage device. 
 

IMPORTANT: The “LDCtoRS_[Jurisdiction]_[date].zip” file contains a great deal of information that could be useful  
for emergency data recovery purposes. The RoadSoft team strongly recommends that every day you save a copy of the 
“LDCtoRS_[Jurisdiction]_[date].zip” file in a permanent archive to facilitate data recovery. 
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STEP 7 
Import the collected data to RoadSoft 
 
 
 

IMPORTANT: Before you import new data into RoadSoft, please backup your existing RoadSoft database. To do so, 
select the Tools menu, then Run Database Manager from the RoadSoft main menu. RoadSoft has to shut down to 
run the Database Manager. You can restart RoadSoft after backing up the data. 
 

a. In the main RoadSoft window, open the TAMC menu and select 2 - (County/City Does This) Import 
TAMC PASER Data from LDC… 

 
b. If you haven’t already backed up your RoadSoft data, click the Yes button to open the RoadSoft Database 

Manager and create a backup, then proceed with importing your collected data. If you already backed up your 
data, click the No button to continue with the import. 
 

c. In the Import Data from LDC window, click the Browse For File to Import button, and then locate the 
“LDCtoRS_[Jurisdiction]_[date].zip” file. 

 
d. Click the OK button to close the confirmation and restart RoadSoft. 
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STEP 8 
Export RoadSoft asset management data for the regional version of 
RoadSoft 
 

 
a. In the main RoadSoft window, open the TAMC menu and select 3 - (County/City Does This) Export 

TAMC PASER Data to Region... 
 

 
 

b. In the Export Path field, enter a location on your hard drive to save the export file. Click the Browse Folder 
button to browse your hard drive. 

 
c. Click OK when your export has been completed successfully.  

 
d. RoadSoft creates a file named “TAMC_[jurisdiction]_[date].zip” in the location you specified. Copy this file to 

a CD, floppy disk, or other portable storage device for import into the Region’s version of RoadSoft. 
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STEP 9 
Import RoadSoft asset management data from the local agency into the 
regional version of RoadSoft 
 
 

IMPORTANT: Before you import new data into RoadSoft, backup your existing RoadSoft database. To do so, open the 
Tools menu and select Run Database Manager from the RoadSoft main menu. RoadSoft has to shut down to run the 
database manager. You can restart RoadSoft after backing up the data. 
 

a. In the main RoadSoft window, open the TAMC menu and select 4 - (Region Does This) Import TAMC 
PASER from County/City… 

 
e. If you haven’t already backed up your RoadSoft data, click the Yes button to open the RoadSoft Database 

Manager and create a backup, then proceed with importing your collected data. If you already backed up your 
data, click the No button to continue with the import. 
 

f. In the Import Data from LDC window, click the Browse For File to Import button, and then locate the 
“TAMC_[Jurisdiction]_[date].zip” file. 

 
NOTE: The Import RoadSoft Data screen lists the last four “TAMC_[jurisdiction]_[date].zip” files that you imported. If 
this is the first time you’re importing data, the screen will appear blank as above.   

 
g. Click the OK button to close the confirmation and restart RoadSoft. 
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STEP 10 
Export shapefile and submit it to the TAMC through the CSS Investment 
Reporting Tool Data Upload page: 
http://tamc.mcgi.state.mi.us/TAMC/ 

 
NOTE: Once ALL local road data is complete in a particular county, export the county’s shape file. This export will 
include ALL road data for a particular county or city (ds and federal-aid) not just the local road data. Using this 
process to submit local road data should not interfere with federal-aid data submission. If you have any questions or 
concerns, please call RoadSoft support at 906-487-2102. 
 

a. In the main RoadSoft window, open the TAMC menu and select 5 - (Region Does This) Export TAMC 
Shape File to Council (Individual County Files)...  

 
NOTE: Do NOT use the standard RoadSoft Shapefile Export, that export is different than the TAMC export. 

 
 
b. Select the County you wish to export using 
the drop-down menu in the Export County 
field. 
 
 
 
c. In the Save Export Data to field, enter 
the name of the county you are exporting. 
 
 
 
d. In the Shapefile Name field, enter the 
name of the county you are exporting 2010 local 
road data for. 
 
 
e. Click the Export button to export the data to 
a location on your hard drive. 
 
 
 
f. Upload the exported file to TAMC using the 
CSS Investment Reporting Tool (IRT) web site: 
http://tamc.mcgi.state.mi.us/TAMC/ 
 


