
 
 

 

 
 

 
 
 
 
 
 
 
 
 

 
 
IMPORTANT NOTE: These instructions are meant for agencies that have not begun to 
collect local road rating data for submission to the Transportation Asset Management 
Council (TAMC) for reimbursement. If your agency already has 2008 local road data 
collected, be sure to call Michigan LTAP & the TDG for assistance before submitting 
data to TAMC through your regional or metropolitan planning organization. 
 
LTAP / TDG Phone: 906-487-2102 
 
 
 
 
 
 
 
 
 
 

Michigan LTAP & the Technology Development Group 
Michigan Tech Transportation Institute 

September 2008 

Submitting Local Road Data to TAMC 
 

Ten Steps to Consistent Data 
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Local Road Ratings Data Cycle 

 

 

 

 

 

 

 
 

The process to collect & submit local road data to the Transportation Asset Management 
Council (TAMC) is similar to that used when submitting data for federal-aid roads. Be sure 
that you are using RoadSoft Version 6.8.5 for local road data collection. 
 
If you have any questions or concerns, please call RoadSoft support at 906-487-2102 
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At the Local Agency Office (County Road Commission, City, Village) 
Using the Local Agency’s version of RoadSoft 

STEP 1 
Define and save a network in RoadSoft for collecting data on paved, local roads/streets. 

a. Start the RoadSoft software. 

b. From the main RoadSoft screen click the funnel button  to open the Network Builder utility. 

c. Set values in the Network/Filter Builder screen, as shown below:  

NOTE 
This step must be done twice: first to select the correct National Function Class, second to select the Surface 
Type. The first set of criteria should be National Function Class = 9-Rural Local, 19-Urban Local. The 
second criteria set defines your Surface Type, and should include only the paved roads in your local road 
network (e.g. asphalt, seal coat, brick, concrete, etc.). 

 

TIP 
To select multiple values hold down the control key while left-clicking. 
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d. Click the Add Criteria button to create the network. 

e. Click the Save button, and then enter a name in the Save Network/Filter screen, as shown below. 
 

 
 

TIP 
Using a descriptive file name and adding a date to the network name can help to ensure that you export the 
correct network. 
 

f. Click the OK button to save the network. 

g. Click the  button to close the Network/Filter Builder window. 

 

 

STEP 2 
Export the Network for use with the Laptop Data Collector (LDC). 

a. From the RoadSoft main menu, select TAMC > 1 - (County/City Does This) Export Data for LDC. 

NOTE 
The regional version of RoadSoft is not capable of exporting data for the LDC. Regions must get data exports 
directly from each local agency within their region. If you have questions please call RoadSoft Technical 
Support at 906-487-2102.    

b. Select the network from the drop down list in the Export Data for LDC screen, as shown below. The network 
you want is the one you saved in Step 1e above. 
 

 
 

c. Define an Export Path, which is the location on your hard drive where you want to save the export file.  

d. Click the Export button to save the export file to the location you specified. 

NOTE 

If you have previously exported TAMC data for the LDC, RoadSoft will indicate that the new file will overwrite 
the old export file. Click Yes and the prompt to continue. 

e. RoadSoft creates a file named “RStoLDC [jurisdiction] [date].zip” in the location you specified. Copy this file 
to a CD, floppy disk, or other portable storage device for importing into the LDC. 
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At the Local Agency Office 
Using the LDC 

STEPS 3&4  
Steps 3 and 4 involve importing the network from the local agency’s version of RoadSoft into the LDC, and then 
loading the local agency’s GIS shape file. The GIS shape file is on the Local Agency’s RoadSoft Program CD. If 
you’re not able to get the CD, call the TDG at 906-487-2102 and specify the jurisdiction you need. They will send 
you a current shape file. 
 
NOTE 
The combination of a network and a shape file is referred to as a RoadSoft Data Set. 

There are three possibilities when importing the network and loading the shape file. Identify your situation below, and 
then perform the appropriate procedure: 

Situation 1: If you installed the LDC software and you are running it for the first time you will have to import the 
network, and then load the shape file from the Local Agency’s RoadSoft Program CD. To do so, simply follow the 
prompts when you first start the LDC software. 

Situation 2: If you have the correct shape file but the incorrect network, perform Procedure 1. 

Situation 3: If you have the incorrect shape file and the incorrect network, perform Procedure 2. 

 

Procedure 1: Import the Network 
a. Start the LDC software. 

b. Insert the portable storage device that contains the “RStoLDC [jurisdiction] [date].zip” file from the local 
agency (see Step 2e). 

c. From the main LDC screen select File > Import Data. 
The Import Data screen appears, as shown below. 
 

 
d. Click the Browse for File button to locate the “RStoLDC [jurisdiction] [date].zip” file on the portable storage 

device. 

e. Click the Import button to import the new network. 

 

Procedure 2: Swap the Shape File and then Import the Network 
a. From the LDC main menu select File > Swap Jurisdiction. 

The Insert CD screen opens, indicating that your RoadSoft Program CD must be inserted (below). 
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b. Insert the RoadSoft Program CD from the correct agency. 

c. Click the OK button to replace the existing shape file. 
The LDC loads the new shape file, and then the Data Not Found prompt opens, as shown below. 
 

 
d. Click the OK button. 

The Import Data window opens, as shown below. 
 

 
e. Insert the portable storage device that contains the “RStoLDC [jurisdiction] [date].zip” file from the local 

agency (see Step 2e).  

f. Click the Browse for File button to locate the “RStoLDC [jurisdiction] [date].zip” file on the portable storage 
device. 

g. Click the Import button to import the new network. 

 

 

In the Field 
Using the LDC 

STEP 5 
Connect the GPS to your laptop, and then collect data.  

To Connect the GPS: 

a. Start the LDC software. 

b. Turn off your GPS, and then connect it to your laptop using the Serial or USB connection. 

NOTE 
If you turn on your GPS before connecting it, your mouse pointer may jump around erratically. If this happens, 
turn off your GPS and then restart windows and the LDC software before turning on your GPS again. 

c. Turn on your GPS, and then wait up to two minutes for it to acquire a position. 

d. From the LDC main menu select GPS > Connect to establish communication between the GPS and the LDC 
software, and then wait a few minutes for the software to snap to a road segment on the GIS map based on the 
position from the GPS. 
  
NOTE 
If you’re not on or near a road segment that is part of the network that you imported into the LDC software, the 
software will not be able to snap to a segment on the GIS map. 
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To Collect Data: 

Use the following shortcut keys to enter data into the LDC software: 

Ctrl + S  Surface Type 

Ctrl + 0–9  PASER Rating 

Shift-Ctrl + 0–9 Number of Lanes 

Ctrl + Enter  Submit (save) Data  

Ctrl + +/-  Zoom In/Out 

Ctrl + Arrow Keys Pan the GIS Map  

Ctrl + Space Bar Hold/Release Segment 

For a complete list of shortcut keys, select Help > Shortcut Keys from the LDC main menu. 

IMPORTANT 
While collecting data, back up every hour or as often as conveniently possible. From the main LDC menu select 
File > Backup/Restore to back up your data. If data collection spans multiple days, export the data every day and save a 
copy of the data file (LDC to RS_[jurisdiction]_[date].zip) to a CD, jump drive, or floppy disk. 
 
TIP 
The RSM History grid (shown below) provides a history of PASER ratings for the current segment. Viewing past PASER 
ratings before rating a segment can influence the rating. To avoid possibly influencing the current rating based on past 
ratings; this grid will not be visible until you submit a rating for the segment.  Editing the rating after that point will 
require an explanation. 
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STEP 6 
After entering new PASER ratings for the entire collection network, export the collected data for the Local 
Agency’s version of RoadSoft. 

a. From the LDC main menu select File > Export Data.  
The Export Data screen opens, as shown below. 
 

 
b. In the Export Path field, enter a location on your hard drive to save the export file. Click the Browse Folder 

button to browse your hard drive. 

NOTE 
Windows will not allow you to export the data directly to a portable storage device. 

c. Click the Export button to export the data. 
If you have an existing data export in the folder you selected in Step 6b, the software will alert you. Click Yes 
to replace the existing file, or click No to append the new data to the existing file. 
When the data export is complete, the following screen appears: 
 

 
d. Click OK to exit the data export process. 

e. Copy the “LDC to RS_[Jurisdiction]_[date].zip” file to a portable storage device. 
 
Important TIP !!! 
The “LDC to RS_[Jurisdiction_[date].zip” file contains a great deal of information that could be useful  for 
emergency data recovery purposes. The RoadSoft team strongly recommends that every day you save a copy of 
the “LDC to RS_[Jurisdiction]_[date].zip” file in a permanent archive to facilitate data recovery. 

 
Import the Collected Data 
Use the Local Agency’s version of RoadSoft at the Road Commission or City 
STEP 7 
Import the collected data. 

IMPORTANT 
Before you import new data into RoadSoft, please backup your existing RoadSoft database. To do so, select  
Tools > Run Database Manager from the RoadSoft main menu. RoadSoft has to shut down to run the Database 
Manager. You can restart RoadSoft after backing up the data. 

a. In the main RoadSoft window, click TAMC > 2—(County/City Does This) Import TAMC PASER Data 
from LDC. 
The Backup RoadSoft Data opens appears, as shown below. 
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b. If you haven’t already backed up your RoadSoft data, click the Run DB Mgr button to open the RoadSoft 
Database Manager, and then go back to Step 7a. If you already backed up your data click the Import Data 
button, and then go to Step 7c. 

c. In the Import Data from LDC Screen (shown below), click the Browse For File button, and then locate the 
“LDC to RS_[Jurisdiction]_[date].zip” file. 
 

 
 

d. Click the Import button to begin the import process. 
 

NOTE 
When the import is complete, RoadSoft will shut down and restart. 
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STEP 8 
Export RoadSoft asset management data for the regional version of RoadSoft. 

a. In the main RoadSoft window, click TAMC >  3 - (County/City Does This) Export TAMC PASER 
Data to Region. 

 The Export RoadSoft Data screen opens.  
 

b. In the Export Path field, enter a location on your hard drive to save the export file. Click the Browse Folder 
button to browse your hard drive. 

c. Click the Export button to export the data. 
If you have an existing data export in the folder you selected in Step 8b, the software will alert you. Click Yes 
to replace the existing file, or click No to append the new data to the existing file. 
When the data export is complete, the following prompt opens: 
 

 
 

d. Click OK to exit the data export process. 
RoadSoft creates a file named “TAMC [jurisdiction] [date].zip” on your hard drive. Copy this file to a portable 
storage device for import into the Region’s version of RoadSoft. 
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At the Region Office 
Using the Region’s version of RoadSoft 
STEP 9 
Import RoadSoft asset management data from the local agency into the regional version of RoadSoft. 

IMPORTANT 
Before you import new data into RoadSoft, please backup your existing RoadSoft database. To do so, select Tools > Run 
Database Manager from the RoadSoft main menu. RoadSoft has to shut down to run the database manager. You can 
restart RoadSoft after backing up the data. 

a. In the main RoadSoft window, click TAMC > 4—(Region Does This) Import TAMC PASER from 
County/City. 
The Backup RoadSoft Data screen opens, as shown below. 
 

 
 

b. If you haven’t already backed up your RoadSoft data, click the Run DB Mgr button to open the RoadSoft 
Database Manager, and then go back to Step 8a. If you already backed up your data click the Import Data 
button, and then go to Step 8c. 

In the Import RoadSoft Data screen (shown below), click Browse for Export to find the “TAMC [jurisdiction] 
[date].zip” file that you want to import, and then click the OK button.  
 

 
 

NOTE 
The Import RoadSoft Data screen lists the last four “TAMC [jurisdiction] [date].zip” files that you imported. If 
this is the first time you’re importing data, the screen will appear blank as above.   

c. In the Import RoadSoft screen (shown below), click Yes to import the data.  
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NOTE 
The data import process takes several minutes. 
 
 

STEP 10 
When all local road data collection is complete in a particular county, export a shape file for that county to the 
Asset Management Council.  The 2008 Local Road data should be submitted through the CGI Investment 
Reporting Tool Data Upload page. Note that this export will include ALL road data for a particular county or 
city, ds and federal-aid), not just the local road data. Using this process to submit local road data should not 
interfere with federal-aid data submission. If you have any questions or concerns, please call RoadSoft support at 
906-487-2102. 

 
http://tamc.mcgi.state.mi.us/TAMC/ 
 

a. In the main RoadSoft window, click TAMC >  5—(Region Does This) Export TMAC Shape File to 
Council (Individual County File).     The Export Layer to Shapefile screen opens, as shown below. 

 NOTE 

Do not use the standard RoadSoft Shapefile Export, that export is different than the TAMC export. 
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b. Select the county you wish to export using the drop-down menu in the Export County field. 

c. In the Save Export Data to field, enter a location on your hard drive to save the file. Click the Browse 
button to browse your hard drive. 

d. In the Shapefile Name field, enter the name of the county you are exporting. 

e. Click the Export button to export the data. 
RoadSoft creates a file named “[County]_[Year].zip” on your hard drive. Copy this file to a portable storage 
device to send to the Asset Management Council using the CGI IRT web site: 

 

http://tamc.mcgi.state.mi.us/TAMC/ 
 


